1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sig error.

Discussion in 'BF2Statistics discussion' started by andrew758, Feb 9, 2006.

  1. andrew758

    andrew758 New Member

    Hey I've got the sig installed and configured correct (i think) , I didn't change what it tracked or the theme just kept it default except the pid. I deleted htaccess file so I can view it using sig.php?id=44034642 (which is my pid) When I load the sig in the browser I am returned with a rather long error, i will write some of the error below:

    Warning imagesx () : supplied argument is not valid Image resource in C:\programfiles\xampp\htdocs\bf2web\bf2sig\themes\default\theme.php on line 24

    the list goes on, but this is default right from your files only thing i changed is delete the htacess file and the pid is the same as default in there.

    Any help would be appreciated, btw I seen kinsman got the sig working and it looks nice, great job niceguy!
     
  2. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Hmm... I havent tried it without mod rewrite! lol

    Let me do some testing, and i'll edit here when i'm done. :)

    **EDIT** You have GD enabled right? If not, enable it.... Have you set the permissions to 777 on the statsxml folder?
    Mine works with the sig.php?id=44771621, with and without the .htaccess file.

    What i'm shure of, is that it has to be your server config... ;)
     
  3. anuj

    anuj New Member

    Any chance to see the code? I'm decent with PHP's GD functions, but it's hard to check what is missing with just one error message.
     
  4. andrew758

    andrew758 New Member

    How do I enable GD and how do I set permsissions to 777?
     
  5. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Google is your friend! :)

    Go to the “php.ini” and under the “Dynamic Extensions “ you will see “extension_dir = c:/php/includes” and “extension=php_gd.dll” Uncomment the line (i.e. remove the ; before the line)and ensure that you have the “php_gd.dll” in the specific directory.

    If you dont have the dll

    download the binaries from the PHP site and extract all the DLL’s to separate folder say “includes”. Copy the folder to the existing PHP directory. Follow the procedure mentioned above.

    Now to the CHMOD to 777

    If you are on windows, just make shure it has read/write permissions.
    If you are on linux see here

    **EDIT**
    BTW are this path right? C:\programfiles\xampp\htdocs\bf2web\bf2sig\themes\default\theme.php
     
  6. andrew758

    andrew758 New Member

    Ok I dont have php_extentension=php_gd.dll I have php_extension=php_gd2.dll should I add the other line?
     
  7. andrew758

    andrew758 New Member

    Yes the path is correct, like I said everything is default.

    heres some more of the error:

    imagecopy () : supplied argument is not a valid Image rsource in C:\program files\xampp\htdocs\bf2web\bf2sig\themes\default\theme.php line 241
    imagedestroy () : imagecopy () : supplied argument is not a valid Image rsource in C:\program files\xampp\htdocs\bf2web\bf2sig\themes\default\theme.php line 242
    Cannot modify header information - headers already sent by (output started at C:\program files\xampp\htdocs\bf2web\bf2sig\themes\default\theme.php:241)
     
  8. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Okey, if you have the line: php_extension=php_gd2.dll, just uncomment it in php.ini, and check that you have the .dll file... :)
     
  9. andrew758

    andrew758 New Member

    It came uncommented and I have the dll file, everything defualt.... still doesnt work.
     
  10. MrNiceGuy

    MrNiceGuy Founder Staff Member

    okey, then it should work.
    Next step, do you have a xml file in the statsxml folder?
     
  11. andrew758

    andrew758 New Member


    yes
     
  12. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Could you open it in notepad or something, and paste what you got in there?
     
  13. andrew758

    andrew758 New Member

    1
    44034642
     
  14. andrew758

    andrew758 New Member

    any ideas?
     
  15. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Hmmm... Yes... it doesnt read you backend correctly.

    Are the sig script on the same machine as the web server?

    If not, check the config.php, change [blockquote]$asp = 'http://localhost/ASP'; #path to asp dir[/blockquote] and before you run the sig again, delete the xml file.

    That goes for any changes made in the sig, you HAVE to delete the xml file, for the changes to take effect. ;)

    And again, does the xml folder/file have read/write access?
     
  16. andrew758

    andrew758 New Member

    yes it is on same machine as web server (duh) and has read write access.
     
  17. andrew758

    andrew758 New Member

    Stoß!
     
  18. MrNiceGuy

    MrNiceGuy Founder Staff Member

    I am out of options... :?
     
  19. MrNiceGuy

    MrNiceGuy Founder Staff Member

  20. andrew758

    andrew758 New Member

    Mine looks nothing like yours, lol. I still don't understand what I am doing wrong.