Public Stats backend and services

Discussion in 'News' started by MrNiceGuy, Apr 15, 2021.

  1. Sunnyghost

    Sunnyghost Member

    Your server is listed in the serverbrowserlist now :).
    When I try to connect i get: "You have failed to connect. Please check your network connections and try again".
     
    MrNiceGuy likes this.
  2. Wilson212

    Wilson212 Administrator Staff Member

    This sounds like the bf2 server ports are closed
     
  3. Sunnyghost

    Sunnyghost Member

    I can't even login using the "join server" option in GamespyRedirector. I could login before using this "join server" option.
     
    MrNiceGuy likes this.
  4. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Hey! It says "Service is online" in the redirector now :D

    I found a script which listed that port as udp, so.. Well my bad :rolleyes:

    Have tried to save the steps i have done when installing.

    Thought about creating a linux install script, which would make it really simple to get everything set up.

    Native linux support for the GameSpy emulator would be awesome. Not ideal to be running anything on a server with Wine :eek:
     
    Sunnyghost likes this.
  5. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Oh, i see the ports are being blocked in the firewall. Thanks for testing!

    Right, I'll just have to figure this out. Hang on.
     
    Sunnyghost likes this.
  6. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Please try again. :)
     
    Sunnyghost likes this.
  7. Sunnyghost

    Sunnyghost Member

    Same error :(
     
  8. Wilson212

    Wilson212 Administrator Staff Member

    Wine? Ouch, yes I will work on getting that ported over to c++. A Linux install script would be pretty sweet for new users!
     
    Sunnyghost and MrNiceGuy like this.
  9. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Okay, now test. I forgot to add port 16567 o_O
     
    Sunnyghost likes this.
  10. Sunnyghost

    Sunnyghost Member

    YESSSSS I am in now :)
     
    MrNiceGuy likes this.
  11. MrNiceGuy

    MrNiceGuy Founder Staff Member

    That's great. Yeah, I'm all for simplifying it for new users. Been working on bash scripting for a while now, and it's pretty fun. :D

    Sweet, then it's good to go.

    Thanks again for testing!
     
    Sunnyghost and Wilson212 like this.
  12. Wilson212

    Wilson212 Administrator Staff Member

    Sunnyghost likes this.
  13. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Sunnyghost likes this.
  14. Wilson212

    Wilson212 Administrator Staff Member

    Still cant connect
     
  15. MrNiceGuy

    MrNiceGuy Founder Staff Member

    That's really weird. There's no blocks in the firewall after i added the 16567 port. :confused:

    I'll see if i can figure it out later today.
     
    Sunnyghost likes this.
  16. Sunnyghost

    Sunnyghost Member

    I cant login anymore. "connecting to account server".
    After 20 seconds, "the server has refused the connection".

    Is your gamespy emulator active? I get the same error on my system when i shut down the gamespy emulator.
     
    Last edited: Apr 16, 2021
  17. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Restarted the services now, both connected and running successfully.
     
    Sunnyghost likes this.
  18. Sunnyghost

    Sunnyghost Member

    Sorry, still the same error message :(. Should be firewall related issue.

    Yesterday I noticed that connecting to your account server takes a long time, even when it was working okay. Connecting to the BF2hub or my own account server takes about 3 seconds. Connecting to yours takes at least 10 seconds. Maybe i got "connection refused" because of a timing issue?
     
    Last edited: Apr 16, 2021
  19. MrNiceGuy

    MrNiceGuy Founder Staff Member

    Yeah, definitely the firewall... Just have to figure out what it is. :oops:
     
  20. MrNiceGuy

    MrNiceGuy Founder Staff Member

    If anyone else with a working server wants to point it to this backed, that would be helpful.

    Gonna try and install a full server bundle, since i did a minimal install, i suspect some packages are missing. (Might have done this mistake in the past) :rolleyes:

    *Edit
    Well, there are DNS issues with this VPS atm.

    I'll post back when it's fixed.
     
    Last edited: Apr 16, 2021

Share This Page