Solved How to set everything up to play singleplayer with saved progress?

Discussion in 'BF2Statistics discussion' started by Paras, Apr 18, 2021.

  1. Paras

    Paras New Member

    I'd like to set up a server/ game to play singleplayer - only me with and against bots but also with all the stuff you earn gets saved for the next time you play.

    I was kinda able to set pretty much everything up (even that there are still some minor problems) but progress will not save. Every time I quit all the earned ranks, medals etc. are lost and the next time I play I have to start from 0 again. I can't figure out how to make it work...

    So is there any way to make this happen? What do I need for that or how to set everything up to make it work?
     
  2. Wilson212

    Wilson212 Administrator Staff Member

    Are you using the ASP 3.1 or the Control Center?
     
    Paras likes this.
  3. Paras

    Paras New Member

    Im using the Control Center but by the way... what is this ASP 3.1? I have the ASP Stats Server enabled... even that I not know if everything is correctly set up
     
  4. Wilson212

    Wilson212 Administrator Staff Member

    Alright, go to the install folder where the control center is located, and open the "Logs" folder. Are there any contents in the "Error.log" ?
     
    Paras likes this.
  5. Paras

    Paras New Member

    ehm... yes... quite alot to be honest
    that should be them:
    - WARNING: Error occured while trying to fetch the new release version:
    - Unable to REMOVE the Readonly rule on Hosts File:
    - NOTICE: Mod "stats" Does not contain a Levels folder
     
  6. Wilson212

    Wilson212 Administrator Staff Member

    Are you running the control center as an admin?
     
    Paras likes this.
  7. Paras

    Paras New Member

    yes I do
     
  8. Paras

    Paras New Member

    -Gamespy Redirects is not enabled due I have no idea how to set it up
     
  9. Wilson212

    Wilson212 Administrator Staff Member

    Ok, well the gamespy redirect do need to be enabled for the system to work. Just set your redirect address' to "127.0.0.1" (this is your local computers address).
     
    Paras likes this.
  10. Wilson212

    Wilson212 Administrator Staff Member

    Should look like this:

    [​IMG]

    [​IMG]

    [​IMG]
     
    Paras likes this.
  11. Paras

    Paras New Member

    nice thanks
     
  12. Paras

    Paras New Member

    so let me try if this will work now
     
  13. Wilson212

    Wilson212 Administrator Staff Member

    The ASP 3.1 is for larger communities. It uses a MySQL database and web server.. so think if you had a clan of 20+ members, you would use the ASP instead of the control center for private stats
     
    Paras likes this.
  14. Paras

    Paras New Member

    oh I see
    Im still testing if everything is working but looks like it really does. Thanks alot - I mean really - I am very grateful I almost despaired of this:)
    I thought Gamespy Redirect would only be necessary for playing with other people... as I said - no ideas :confused:
     
  15. Paras

    Paras New Member

    hmm okay... unfortunately there is still a problem... It does save as long as the server is up but when I close the server all of my progress is gone. It seems like it saves the progress of the bots but not mine. At least my rank is gone but some bots still got theirs...
    I've even inserted my account in the options of the Gamespy Emulator tab (Manage Accounts)... was this wrong?
    Do you maybe have an idea what's the problem and how I can fix it?
     
  16. Wilson212

    Wilson212 Administrator Staff Member

    Are you using a fake online account? (Having to entry a username / password in BF2 to login)
     
    Paras likes this.
  17. Paras

    Paras New Member

    Not sure if it is fake or not but it is online... I think I might see the problem... I can't use that account but have to use an offline account right?
     
  18. Wilson212

    Wilson212 Administrator Staff Member

    Contrary, need to use an online account
     
    Paras likes this.
  19. MrNiceGuy

    MrNiceGuy Founder Staff Member

    @Paras Hello, did you register the account after everything was set up? I think it needs to be registered in the same database your server uploads the snapshot to. If the account is registered elsewhere, the stats will be lost, if that makes sense? :)
     
  20. Paras

    Paras New Member

    I did before everything was set up and well... I have no idea how to check what database it is registered in. I checked for my PID, entered it as well as my nick, password and the mailadress I've registered my account and it did also show up in the log so I think it acctualy should
     

Share This Page